Instalação do OJS

Versão do OJS 3.1.1.4

Obrigado por baixar o Open Journal Systems do Public Knowledge Project. Antes de prosseguir, leia o arquivo README incluídoeste software. Para obter mais informações sobre o Projeto de conhecimento público e seus projetos de software, visite o site da PKP. Se você tiver relatórios de erros ou consultas de suporte técnico sobre o Open Journal Systems, consulte o fórum de suporte ou visite o PKP online sistema de relatório de erros. Embora o fórum de suporte seja o método preferido de contato, você também pode enviar um e-mail à equipe em pkp.contact@gmail.com.

Atualização

Se você estiver atualizando uma instalação existente do OJS, clique aqui para continuar.

Requisitos recomendados do sistema

Como a PKP não possui recursos para testar todas as combinações possíveis de versões e plataformas de software, nenhuma garantia de operação correta ou suporte está implícita.

As alterações a essas configurações podem ser feitas após a instalação, editando o arquivo config.inc.php no diretório base OJS, ou usando a interface da web de administração do site.

Sistemas de banco de dados suportados

O OJS já foi testado no MySQL e no PostgreSQL, embora outros sistemas de gerenciamento de banco de dados suportados pelo ADOdb possam funcionar (total ou parcialmente). Os relatórios de compatibilidade e / ou patches de código para SGBDs alternativos podem ser enviados para a equipe do OJS.

Passos de pré-instalação

1. Os seguintes arquivos e diretórios (e seus conteúdos) devem ter permissão de escrita:

  • config.inc.php é gravável (opcional): Sim
  • público/ é gravável: Sim
  • cache/ é gravável: Sim
  • cache/t_cache/ é gravável: Sim
  • cache/t_compile/ é gravável: Sim
  • cache/_db é gravável: Sim

2. Um diretório para armazenar os arquivos de submissão deve ser criado e com permissão de escrita (consulte "Configurações do arquivo" abaixo).

Conta do administrador

Este usuário será o Administrador do Portal e terá acesso completo ao sistema. Contas adicionais podem ser criadas após a instalação.

Usuário
Senha
Repetir senha
E-mail
Configurações de idioma (Localização)

Para suporte total ao Unicode (UTF-8), escolha UTF-8 para todas as configurações de caracteres. Note que o suporte requer o MySQL >= 4.1.1 ou PostgreSQL >= 7.1. Suporte total ao Unicode requer o PHP >= 4.3.0 compilado com suporte à bibliotecambstring (habilitada em instalações padrão de versões mais recentes do PHP). Problemas com conjuntos de caracteres podem ocorrer caso estes requisitos não sejam atendidos pelo servidor.

O servidor atualmente tem suporte a mbstring: Sim

Idiomas adicionais
Conjunto de caracteres do Cliente
Conjunto de caracteres da conexão
Conjunto de caracteres da base de dados
Configurações de arquivos
Diretório para envio de arquivos

Seu servidor permite envio de arquivos: Sim

Seu servidor permite atualmente envio de arquivos no tamanho máximo de: 2M

Configurações de bases de dados

O sistema exige acesso a uma base de dados SQL para armazenar seus dados. Verifique os requisitos do sistema para a lista de bases de dados suportadas. Nos campos a seguir, informe as configurações a serem utilizadas para conexão ao servidor de bases de dados.

Driver da base de dados
Servidor
Usuário da base de dados
Senha para acesso à base de dados
Nome da base de dados
Configurações OAI
Identificador para repositório OAI
Sinalizador